diff pyproject.toml @ 36:cb990883e52f

deployment; dep updates
author drewp@bigasterisk.com
date Sun, 12 Nov 2023 23:19:23 -0800
parents 6f0b31ac587e
children c4e8d697326b
line wrap: on
line diff
--- a/pyproject.toml	Tue Aug 22 12:47:28 2023 -0700
+++ b/pyproject.toml	Sun Nov 12 23:19:23 2023 -0800
@@ -6,23 +6,21 @@
     {name = "Drew Perttula", email = "drewp@bigasterisk.com"},
 ]
 dependencies = [
-    "pymongo>=4.2.0",
+    "pymongo>=4.6.0",
     "python-dateutil>=2.8.2",
-    "uvicorn[standard]>=0.18.2",
-    "gcsa>=1.3.0",
-    "google-api-python-client>=2.54.0",
+    "uvicorn[standard]>=0.24.0post1",
+    "gcsa>=2.1.0",
+    "google-api-python-client>=2.107.0",
     "oauth2client>=4.1.3",
     "rdflib>=6.1.1",
-    "starlette-exporter>=0.13.0",
-    "starlette>=0.20.4",
-    "yapf>=0.32.0",
-    "toml>=0.10.2",
+    "starlette-exporter>=0.17.1",
+    "starlette>=0.32.0post1",
 
     "patchablegraph>=1.5.0",
     "rdfdb==0.24.0",
-    "background-loop>=1.7.0",
+    "background-loop>=1.8.0",
 ]
-requires-python = ">=3.10"
+requires-python = ">=3.11"
 license = {text = "MIT"}
 
 [build-system]
@@ -32,4 +30,23 @@
 [[tool.pdm.source]]
 url = "https://projects.bigasterisk.com/"
 verify_ssl = true
-name = "home"
\ No newline at end of file
+name = "home"
+
+[tool.ruff]
+ignore = []
+
+exclude = [
+    ".hg",
+    ".ruff_cache",
+    ".venv",
+    "__pypackages__",
+    "dist",
+    "node_modules",
+]
+
+line-length = 160
+
+# Allow unused variables when underscore-prefixed.
+dummy-variable-rgx = "^(_+|(_+[a-zA-Z0-9_]*[a-zA-Z0-9]+?))$"
+
+target-version = "py311"
\ No newline at end of file