diff pyproject.toml @ 36:7ed47f59f22a

use pdm
author drewp@bigasterisk.com
date Sat, 19 Nov 2022 17:02:46 -0800
parents
children 530650b3bc40
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/pyproject.toml	Sat Nov 19 17:02:46 2022 -0800
@@ -0,0 +1,39 @@
+[project]
+name = ""
+version = ""
+description = ""
+authors = [{ name = "", email = "" }]
+dependencies = [
+    "argparse==1.4.0",
+    "beautifulsoup4==4.9.3",
+    "bottle==0.12.19",
+    "cherrypy==18.6.1",
+    "cssselect==1.1.0",
+    "gunicorn==20.1.0",
+    "http-parser==0.9.0",
+    "lxml==4.6.3",
+    "prometheus_client==0.8.0",
+    "pyjade==4.0.0",
+    "pymongo==3.12.0",
+    "pystache==0.6.0",
+    "python-dateutil==2.8.2",
+    "requests==2.26.0",
+    "six",
+    "rdflib>=6.2.0",
+    "pyjwt>=2.4.0",
+    "cryptography>=38.0.3",
+    "ipython>=8.6.0",
+]
+requires-python = ">=3.10"
+license = { text = "MIT" }
+
+[tool.pdm]
+
+[[tool.pdm.source]]
+name = "pypi"
+url = "https://pypi.org/simple"
+verify_ssl = true
+
+[build-system]
+requires = ["pdm-pep517"]
+build-backend = "pdm.pep517.api"