diff pyproject.toml @ 326:5b88b38f2471

huge reorg, reog toplevel functions in preparation of a ui with nice task lists
author drewp@bigasterisk.com
date Mon, 20 Jan 2025 21:55:08 -0800
parents be6b2695542c
children
line wrap: on
line diff
--- a/pyproject.toml	Mon Jan 20 14:10:19 2025 -0800
+++ b/pyproject.toml	Mon Jan 20 21:55:08 2025 -0800
@@ -6,9 +6,11 @@
     {name = "", email = ""},
 ]
 dependencies = [
-    "pyinfra>=3.1",
+    "pyinfra>=3.2",
     "more-itertools>=10.2.0",
     "psutil>=5.9.8",
+    "rdflib>=7.1.3",
+    "invoke>=2.2.0",
 ]
 requires-python = ">=3.11"
 license = {text = "MIT"}
@@ -17,4 +19,3 @@
 requires = ["pdm-pep517>=1.0.0"]
 build-backend = "pdm.pep517.api"
 
-[tool.pdm]