diff pyproject.toml @ 0:5a77696c6dab

start
author drewp@bigasterisk.com
date Sun, 28 Jan 2024 15:32:18 -0800
parents
children 181a86533286
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/pyproject.toml	Sun Jan 28 15:32:18 2024 -0800
@@ -0,0 +1,51 @@
+[project]
+name = "light-bridge"
+version = "0.0.1"
+description = ""
+authors = [
+    {name = "Drew Perttula", email = "drewp@bigasterisk.com"},
+]
+dependencies = [
+    "ruff>=0.0.286",
+    "starlette-exporter>=0.13.0",
+    "starlette>=0.20.4",
+    "uvicorn[standard]>=0.18.2",
+
+    "background-loop>=1.3.0",
+    "patchablegraph>=1.5.0",
+    "rdfdb==0.24.0",
+]
+requires-python = ">=3.11"
+license = {text = "MIT"}
+
+[build-system]
+requires = ["pdm-pep517>=1.0.0"]
+build-backend = "pdm.pep517.api"
+
+[[tool.pdm.source]]
+url = "https://projects.bigasterisk.com/"
+verify_ssl = true
+name = "home"
+
+[tool.ruff]
+ignore = []
+
+exclude = [
+    ".hg",
+    ".ruff_cache",
+    ".venv",
+    "__pypackages__",
+    "dist",
+    "node_modules",
+]
+
+line-length = 160
+
+# Allow unused variables when underscore-prefixed.
+dummy-variable-rgx = "^(_+|(_+[a-zA-Z0-9_]*[a-zA-Z0-9]+?))$"
+
+target-version = "py311"
+
+["tool.ectoscope"]
+cookiecutter-path = "/my/proj/ectoscope/cookie/skeleton"
+cookiecutter-rev = "b421cb90fed4"