diff pyproject.toml @ 2377:2088c500415e

pdm & homepage fixes
author drewp@bigasterisk.com
date Sun, 12 May 2024 19:03:41 -0700
parents 1aaa449e89d0
children 0d88befa5132
line wrap: on
line diff
--- a/pyproject.toml	Sun May 12 19:02:10 2024 -0700
+++ b/pyproject.toml	Sun May 12 19:03:41 2024 -0700
@@ -1,9 +1,9 @@
 [project]
-name = ""
-version = ""
+name = "light9"
+version = "0.0.1"
 description = ""
 authors = [{ name = "Drew Perttula", email = "drewp@bigasterisk.com" }]
-license-expression = "MIT"
+license = {text = "MIT"}
 dependencies = [
     "pillow",
     "pyjade",
@@ -42,13 +42,15 @@
     "mido>=1.2.10",
     "alsa-midi>=1.0.1",
     "treq>=22.2.0",
+    "light9 @ file:///${PROJECT_ROOT}/",
 ]
-requires-python = ">=3.10"
+requires-python = ">=3.11"
+
+readme = "README.md"
 
 [project.urls]
-Homepage = ""
+Homepage = "https://bigasterisk.com/light9/"
 
-[project.optional-dependencies]
 [tool.pdm]
 
 [tool.pdm.dev-dependencies]