diff pyproject.toml @ 2165:87c011a5e99f

more specific py versions, some cleanup. update rdfdb
author drewp@bigasterisk.com
date Thu, 18 May 2023 12:18:50 -0700
parents 2973ec5df7e4
children 679cafb867b1
line wrap: on
line diff
--- a/pyproject.toml	Thu May 18 12:18:05 2023 -0700
+++ b/pyproject.toml	Thu May 18 12:18:50 2023 -0700
@@ -5,50 +5,45 @@
 authors = [{ name = "Drew Perttula", email = "drewp@bigasterisk.com" }]
 license-expression = "MIT"
 dependencies = [
-    "autobahn",
-    "coloredlogs",
-    "colormath",
     "cyclone",
-    "genshi",
-    "ipython",
-    "klein",
-    "louie",
-    "moviepy",
-    "noise",
     "pillow",
-    "pyftdi",
     "pyjade",
     "pyserial",
-    "python-dateutil",
     "pyusb",
-    "rdflib",
-    "requests",
-    "rx",
-    #    "scipy",
     "service_identity",
-    "statprof",
-    "toposort",
     "treq",
     "twisted",
     "txzmq",
-    "udmx-pyusb",
-    "webcolors>=1.11.1",
-    "watchdog>=2.1.7",
-    "standardservice @ https://projects.bigasterisk.com/standardservice/standardservice-0.6.0.tar.gz",
-    "cycloneerr @ https://projects.bigasterisk.com/cycloneerr/cycloneerr-0.4.0.tar.gz",
-    "web.py>=0.62",
-    "uvicorn[standard]>=0.17.6",
-    "starlette[standard]>=0.19.0",
+    "aiohttp>=3.8.1",
+    "coloredlogs>=15.0.1",
+    "colormath>=3.0.0",
+    "flask==2.2.4",
+    "ipython>=8.13.2",
+    "louie>=2.0",
+    "moviepy>=1.0.3",
+    "noise>=1.2.2",
     "prometheus-client>=0.14.1",
-    "starlette-exporter>=0.12.0",
+    "pydmxcontrol>=2.0.0",
     "PyGObject>=3.42.1",
-    "aiohttp>=3.8.1",
-    "rdfdb @ https://projects.bigasterisk.com/rdfdb/rdfdb-0.23.0.tar.gz",
+    "python-dateutil>=2.8.2",
+    "rdflib>=6.3.2",
+    "requests>=2.30.0",
+    "rx>=3.2.0",
     "sse-starlette>=0.10.3",
-    "pydmxcontrol>=2.0.0",
-    "flask==2.2.4",
+    "starlette-exporter>=0.12.0",
+    "starlette>=0.27.0",
+    "statprof>=0.1.2",
+    "toposort>=1.10",
+    "udmx-pyusb>=2.0.0",
+    "uvicorn[standard]>=0.17.6",
+    "watchdog>=2.1.7",
+    "web.py>=0.62",
+    "webcolors>=1.11.1",
+    "cycloneerr @ https://projects.bigasterisk.com/cycloneerr/cycloneerr-0.4.0.tar.gz",
+    "rdfdb @ https://projects.bigasterisk.com/rdfdb/rdfdb-0.24.0.tar.gz",
+    "standardservice @ https://projects.bigasterisk.com/standardservice/standardservice-0.6.0.tar.gz",
 ]
-requires-python = ">=3.9"
+requires-python = ">=3.10"
 
 [project.urls]
 Homepage = ""
@@ -65,7 +60,6 @@
     "ipdb",
     "mock",
     "mypy",
-    "nose-watcher",
     "nose",
     "pytest-watcher",
     "pytest",