diff pyproject.toml @ 2167:aecbcddccfea

get pytest running
author drewp@bigasterisk.com
date Thu, 18 May 2023 14:13:40 -0700
parents 679cafb867b1
children 8c5a685e6cba
line wrap: on
line diff
--- a/pyproject.toml	Thu May 18 12:56:52 2023 -0700
+++ b/pyproject.toml	Thu May 18 14:13:40 2023 -0700
@@ -36,6 +36,7 @@
     "watchdog>=2.1.7",
     "webcolors>=1.11.1",
     "rdfdb @ https://projects.bigasterisk.com/rdfdb/rdfdb-0.24.0.tar.gz",
+    "scipy>=1.9.3",
 ]
 requires-python = ">=3.10"
 
@@ -47,18 +48,16 @@
 
 [tool.pdm.dev-dependencies]
 dev = [
-    "coverage",
-    "flake8",
-    "freezegun",
-    "hunter",
-    "ipdb",
-    "mock",
-    "mypy",
-    "nose",
-    "pytest-watcher",
-    "pytest",
-    "yapf",
-    "pydeps>=1.10.18",
+    "coverage>=7.2.5",
+    "flake8>=6.0.0",
+    "freezegun>=1.2.2",
+    "hunter>=3.6.1",
+    "ipdb>=0.13.13",
+    "mock>=5.0.2",
+    "yapf>=0.33.0",
+    "pydeps>=1.12.5",
+    "nose2>=0.13.0",
+    "pytest-watch>=4.2.0",
 ]
 
 [[tool.pdm.source]]