diff pyproject.toml @ 2031:e7e3fbae767d

add files related to pdm setup
author drewp@bigasterisk.com
date Thu, 07 Apr 2022 01:09:53 -0700
parents
children f9faa2ec824f
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/pyproject.toml	Thu Apr 07 01:09:53 2022 -0700
@@ -0,0 +1,72 @@
+[project]
+name = ""
+version = ""
+description = ""
+authors = [{ name = "Drew Perttula", email = "drewp@bigasterisk.com" }]
+license-expression = "MIT"
+dependencies = [
+    "autobahn",
+    "coloredlogs",
+    "colormath",
+    "cyclone",
+    "genshi",
+    "ipython",
+    "klein",
+    "louie",
+    "moviepy",
+    "noise",
+    "pillow",
+    "pyftdi",
+    "pyjade",
+    "pyserial",
+    "python-dateutil",
+    "pyusb",
+    "rdflib",
+    "requests",
+    "rx",
+    "scipy",
+    "service_identity",
+    "statprof",
+    "toposort",
+    "treq",
+    "twisted",
+    "txzmq",
+    "udmx-pyusb",
+    "webcolors>=1.11.1",
+    "watchdog>=2.1.7",
+    "standardservice @ https://projects.bigasterisk.com/standardservice/standardservice-0.6.0.tar.gz",
+    "cycloneerr @ https://projects.bigasterisk.com/cycloneerr/cycloneerr-0.4.0.tar.gz",
+    "rdfdb @ https://projects.bigasterisk.com/rdfdb/rdfdb-0.21.0.tar.gz",
+    "web.py>=0.62",
+]
+requires-python = ">=3.9"
+
+[project.urls]
+Homepage = ""
+
+[tool.pdm]
+
+[tool.pdm.dev-dependencies]
+dev = [
+    "coverage",
+    "flake8",
+    "freezegun",
+    "hunter",
+    "ipdb",
+    "mock",
+    "mypy",
+    "nose-watcher",
+    "nose",
+    "pytest-watcher",
+    "pytest",
+    "yapf",
+]
+
+[[tool.pdm.source]]
+name = "pypi"
+url = "https://pypi.org/simple"
+verify_ssl = true
+
+[build-system]
+requires = ["pdm-pep517"]
+build-backend = "pdm.pep517.api"