diff pyproject.toml @ 0:3c86035c0061

start migration from proj/homeauto/espNode
author drewp@bigasterisk.com
date Thu, 27 Jun 2024 13:28:53 -0700
parents
children f340f7a559de
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/pyproject.toml	Thu Jun 27 13:28:53 2024 -0700
@@ -0,0 +1,25 @@
+[project]
+name = ""
+version = ""
+description = ""
+authors = [
+    {name = "Drew Perttula", email = "drewp@bigasterisk.com"},
+]
+dependencies = [
+    "docopt>=0.6.2",
+    "aiohttp>=3.8.1",
+    "aioesphomeapi>=10.11.0",
+    "apriltag>=0.0.16",
+    "numpy",
+    "aiohttp-sse>=2.1.0",
+    "opencv-python",
+    "esphome>=2023.8.2",
+    "pillow>=10.2.0",
+    "setuptools>=69.1.1",
+]
+requires-python = ">=3.11"
+license = {text = "MIT"}
+
+[build-system]
+requires = ["pdm-pep517>=1.0.0"]
+build-backend = "pdm.pep517.api"