diff pyproject.toml @ 28:6a8a7072c8ce

setup.py to pyproject; attempt new package structure
author drewp@bigasterisk.com
date Sun, 24 Apr 2022 00:30:28 -0700
parents
children 0dd0a01c2c6e
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/pyproject.toml	Sun Apr 24 00:30:28 2022 -0700
@@ -0,0 +1,42 @@
+[project]
+name = "patchablegraph"
+version = "1.1.0"
+description = ""
+authors = [
+    {name = "Drew Perttula", email = "drewp@bigasterisk.com"},
+]
+license-expression = "MIT"
+dependencies = [
+        'rdflib >= 6.0.1',
+        'rdfdb >= 0.8.0',
+        'prometheus_client',
+        'sse_starlette>=0.10.3',
+        'starlette>=0.19.1'
+]
+requires-python = ">=3.9"
+
+[project.urls]
+Homepage = ""
+   # url='https://projects.bigasterisk.com/patchablegraph/patchablegraph-1.1.0.tar.gz',
+
+[project.optional-dependencies]
+[tool.pdm]
+[tool.pdm.dev-dependencies]
+dev = [
+    "flake8>=4.0.1",
+    "yapf>=0.32.0",
+    "pytest>=7.1.1",
+    "pytest-watcher>=0.2.3",
+]
+
+[build-system]
+requires = ["pdm-pep517>=0.12.0"]
+build-backend = "pdm.pep517.api"
+
+[tool.pytest.ini_options]
+filterwarnings = [
+    # The below warning is a consequence of how pytest doctest detects mocks and how DefinedNamespace behaves when an undefined attribute is being accessed.
+    'ignore:Code. pytest_mock_example_attribute_that_shouldnt_exist is not defined in namespace .*:UserWarning',
+    # The below warning is a consequence of how pytest detects fixtures and how DefinedNamespace behaves when an undefined attribute is being accessed.
+    'ignore:Code. _pytestfixturefunction is not defined in namespace .*:UserWarning',
+]
\ No newline at end of file