diff setup.py @ 25:e11d407c46f8

rewrite for asyncio and starlette
author drewp@bigasterisk.com
date Sat, 23 Apr 2022 23:58:41 -0700
parents fee5fd30b58c
children 4668117dcd24
line wrap: on
line diff
--- a/setup.py	Sat Apr 23 23:48:55 2022 -0700
+++ b/setup.py	Sat Apr 23 23:58:41 2022 -0700
@@ -2,19 +2,17 @@
  
 setup(
     name='patchablegraph',
-    version='0.19.0',
+    version='1.0.0',
     packages=['patchablegraph'],
     package_dir={'patchablegraph': ''},
     install_requires=[
-        'cyclone',
-        'twisted',
         'rdflib >= 6.0.1',
         'rdfdb >= 0.8.0',
         'prometheus_client',
-        'cycloneerr',
-        'twisted_sse >= 0.3.0',
+        'sse_starlette>=0.10.3',
+        'starlette>=0.19.1'
     ],
-    url='https://projects.bigasterisk.com/patchablegraph/patchablegraph-0.19.0.tar.gz',
+    url='https://projects.bigasterisk.com/patchablegraph/patchablegraph-1.0.0.tar.gz',
     author='Drew Perttula',
     author_email='drewp@bigasterisk.com',
 )