diff pyproject.toml @ 0:3989f073ed9e

start. hardcoded motion light in garage
author drewp@bigasterisk.com
date Thu, 24 Aug 2023 16:28:05 -0700
parents
children b7b6d7f1ce56
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/pyproject.toml	Thu Aug 24 16:28:05 2023 -0700
@@ -0,0 +1,28 @@
+[project]
+name = "pi_mqtt"
+version = "0.0.1"
+description = ""
+authors = [
+    {name = "Drew Perttula", email = "drewp@bigasterisk.com"},
+]
+dependencies = [
+    "starlette-exporter>=0.13.0",
+    "starlette>=0.20.4",
+    "uvicorn[standard]>=0.18.2",
+    "pigpio>=1.78",
+    "background-loop>=1.7.0",
+]
+requires-python = ">=3.11"
+license = {text = "MIT"}
+
+[build-system]
+requires = ["pdm-pep517>=1.0.0"]
+build-backend = "pdm.pep517.api"
+
+[[tool.pdm.source]]
+url = "https://projects.bigasterisk.com/"
+verify_ssl = true
+name = "home"
+[ectoscope]
+cookiecutter-path = "/my/proj/ectoscope/cookie/skeleton"
+cookiecutter-rev = "2462b4f9b0b4"