diff pyproject.toml @ 2:b7b6d7f1ce56

bg loop now crashes if there's an error
author drewp@bigasterisk.com
date Fri, 01 Sep 2023 23:58:24 -0700
parents 3989f073ed9e
children
line wrap: on
line diff
--- a/pyproject.toml	Fri Sep 01 23:57:45 2023 -0700
+++ b/pyproject.toml	Fri Sep 01 23:58:24 2023 -0700
@@ -6,11 +6,12 @@
     {name = "Drew Perttula", email = "drewp@bigasterisk.com"},
 ]
 dependencies = [
+    "ruff>=0.0.286",
     "starlette-exporter>=0.13.0",
     "starlette>=0.20.4",
     "uvicorn[standard]>=0.18.2",
     "pigpio>=1.78",
-    "background-loop>=1.7.0",
+    "background-loop>=1.8.0",
 ]
 requires-python = ">=3.11"
 license = {text = "MIT"}
@@ -23,6 +24,26 @@
 url = "https://projects.bigasterisk.com/"
 verify_ssl = true
 name = "home"
-[ectoscope]
+
+[tool.ruff]
+ignore = []
+
+exclude = [
+    ".hg",
+    ".ruff_cache",
+    ".venv",
+    "__pypackages__",
+    "dist",
+    "node_modules",
+]
+
+line-length = 160
+
+# Allow unused variables when underscore-prefixed.
+dummy-variable-rgx = "^(_+|(_+[a-zA-Z0-9_]*[a-zA-Z0-9]+?))$"
+
+target-version = "py311"
+
+[tool.ectoscope]
 cookiecutter-path = "/my/proj/ectoscope/cookie/skeleton"
 cookiecutter-rev = "2462b4f9b0b4"