diff pyproject.toml @ 91:12bffd51450f

project config
author drewp@bigasterisk.com
date Sun, 15 May 2022 15:47:43 -0700
parents f9282b33b8d0
children 5ebb6129c035
line wrap: on
line diff
--- a/pyproject.toml	Tue Apr 05 09:20:20 2022 -0700
+++ b/pyproject.toml	Sun May 15 15:47:43 2022 -0700
@@ -2,9 +2,7 @@
 name = "rdfdb"
 version = "0.22.0"
 description = ""
-authors = [
-    {name = "Drew Perttula", email = "drewp@bigasterisk.com"},
-]
+authors = [{ name = "Drew Perttula", email = "drewp@bigasterisk.com" }]
 license-expression = "MIT"
 dependencies = [
     'rdflib',
@@ -19,10 +17,12 @@
 
 [project.urls]
 Homepage = ""
-   # url='https://projects.bigasterisk.com/rdfdb/rdfdb-0.21.0.tar.gz',
 
+# url='https://projects.bigasterisk.com/rdfdb/rdfdb-0.21.0.tar.gz',
 [project.optional-dependencies]
+
 [tool.pdm]
+
 [tool.pdm.dev-dependencies]
 dev = [
     "flake8>=4.0.1",
@@ -41,4 +41,8 @@
     'ignore:Code. pytest_mock_example_attribute_that_shouldnt_exist is not defined in namespace .*:UserWarning',
     # The below warning is a consequence of how pytest detects fixtures and how DefinedNamespace behaves when an undefined attribute is being accessed.
     'ignore:Code. _pytestfixturefunction is not defined in namespace .*:UserWarning',
-]
\ No newline at end of file
+]
+asyncio_mode = "strict"
+log_cli = 1
+log_cli_level = "INFO"
+addopts = "--tb=short"