diff pyproject.toml @ 118:418050704a42

fix tests
author drewp@bigasterisk.com
date Tue, 23 May 2023 19:43:57 -0700
parents 489e341f765d
children 6443cb265a2f
line wrap: on
line diff
--- a/pyproject.toml	Tue May 23 16:49:41 2023 -0700
+++ b/pyproject.toml	Tue May 23 19:43:57 2023 -0700
@@ -6,13 +6,13 @@
 license = "MIT"
 dependencies = [
     'rdflib',
-    'autobahn',
+    'autobahn>=23.1.2',
     "prometheus-client>=0.13.1",
     "starlette-exporter>=0.12.0",
-    "asyncinotify>=2.0.2",
+    "asyncinotify>=4.0.2",
     "aiohttp>=3.8.1",
 ]
-requires-python = ">=3.9"
+requires-python = ">=3.10"
 
 [project.urls]
 Homepage = ""
@@ -29,7 +29,7 @@
     "pytest>=7.1.1",
     "pytest-watcher>=0.2.3",
     "mock",
-    "pytest-asyncio>=0.18.3",
+    "pytest-asyncio>=0.21.0",
     "pydeps>=1.10.18",
 ]