diff flow/pyproject.toml @ 10:13438795d896

rewrite with prefect flows and whoosh search, but it's in a nested pdm env
author drewp@bigasterisk.com
date Thu, 11 Jul 2024 17:35:31 -0700
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/flow/pyproject.toml	Thu Jul 11 17:35:31 2024 -0700
@@ -0,0 +1,28 @@
+[project]
+name = "flow"
+version = "0.1.0"
+description = "Default template for PDM package"
+authors = [
+    {name = "", email = ""},
+]
+dependencies = [
+    "prefect>=2.19.7",
+    "lxml>=5.2.2",
+    "httpx>=0.27.0",
+    "cssselect>=1.2.0",
+    "whoosh>=2.7.4",
+    "ipython>=8.26.0",
+]
+requires-python = "==3.11.*"
+readme = "README.md"
+license = {text = "MIT"}
+
+
+[tool.pdm]
+distribution = false
+
+[tool.pdm.scripts]
+_.env_file = "env"
+run_prefect_server = "prefect server start"
+run_build_flow = "python build_index.py"
+start_build = "prefect deployment run buildIndex/buildIndex"
\ No newline at end of file