diff pyproject.toml @ 12:7f36497bfac3

pdm edits in another commit since the lock diffs are probably big
author drewp@bigasterisk.com
date Thu, 11 Jul 2024 18:16:20 -0700
parents d1b54241a731
children 403eff4a16c8
line wrap: on
line diff
--- a/pyproject.toml	Thu Jul 11 18:15:44 2024 -0700
+++ b/pyproject.toml	Thu Jul 11 18:16:20 2024 -0700
@@ -6,21 +6,19 @@
     {name = "drew", email = "drewp@bigasterisk.com"},
 ]
 dependencies = [
+    "cssselect>=1.2.0",
+    "fastapi>=0.111.0",
+    "html5lib>=1.1",
+    "httpx>=0.27.0",
+    "ipdb>=0.13.13",
     "ipython>=8.26.0",
-    "webvtt-py>=0.5.1",
-    "pdfminer>=20191125",
-    "pymilvus[model]>=2.4.4",
-    "ipdb>=0.13.13",
-    "flax>=0.8.5",
+    "lxml>=5.2.2",
     "nltk>=3.8.1",
-    "langchain>=0.2.6",
-    "fastapi>=0.111.0",
-    "apex-search>=0.0.2",
-    "tantivy>=0.22.0",
-    "markdownify>=0.12.1",
-    "lxml>=5.2.2",
-    "html5lib>=1.1",
-    "cssselect>=1.2.0",
+    "webvtt-py>=0.5.1",
+    "whoosh>=2.7.4",
+    #    "flax>=0.8.5",
+    #    "pymilvus[model]>=2.4.4",
+    "prefect>=2.13.4",
 ]
 requires-python = ">=3.11"
 readme = "README.md"
@@ -29,3 +27,9 @@
 
 [tool.pdm]
 distribution = false
+
+[tool.pdm.scripts]
+_.env_file = "env"
+run_prefect_server = "prefect server start"
+run_build_flow = "python build_index.py"
+start_build = "prefect deployment run buildIndex/buildIndex"
\ No newline at end of file