diff pyproject.toml @ 14:b9c2b7fedbcd

fix up deployment and connect ui to server again
author drewp@bigasterisk.com
date Thu, 11 Jul 2024 22:11:41 -0700
parents 403eff4a16c8
children
line wrap: on
line diff
--- a/pyproject.toml	Thu Jul 11 21:32:24 2024 -0700
+++ b/pyproject.toml	Thu Jul 11 22:11:41 2024 -0700
@@ -33,4 +33,5 @@
 run_prefect_server = "prefect server start"
 run_build_flow = "python -c 'from scobot.index.build_index_flow import buildIndex; buildIndex.serve(buildIndex.__name__)'"
 start_build = "prefect deployment run buildIndex/buildIndex"
-run_local_deploy = "fastapi dev --host 0.0.0.0 --port 8001 scobot"
\ No newline at end of file
+run_local_deploy = "fastapi dev --host 0.0.0.0 --port 8001 scobot"
+run_local_vite = {shell = "(cd web; pnpm exec vite)"}