diff pyproject.toml @ 30:1fa90a903621

upgrade many deps
author drewp@bigasterisk.com
date Mon, 26 Aug 2024 22:33:02 -0700
parents 27a754f8e8f8
children 1bd17c2e5517
line wrap: on
line diff
--- a/pyproject.toml	Sat Mar 23 16:11:27 2024 -0700
+++ b/pyproject.toml	Mon Aug 26 22:33:02 2024 -0700
@@ -3,21 +3,22 @@
 [tool.pdm]
 
 [project]
-name = ""
-version = ""
+name = "video"
+version = "0.0.1"
 description = ""
 authors = [{ name = "Drew Perttula", email = "drewp@bigasterisk.com" }]
 dependencies = [
     "docopt",
-    "pymongo==3.10.1",
-    "python-dateutil==2.8.1",
-    "prometheus-client>=0.16.0",
-    "starlette-exporter>=0.15.1",
-    "starlette>=0.26.1",
-    "uvicorn>=0.21.1",
+    "pymongo==4.8.0",
+    "python-dateutil==2.9.0",
+    "prometheus-client>=0.20.0",
+    "starlette-exporter>=0.23.0",
+    "starlette>=0.38.2",
+    "uvicorn>=0.30.6",
     "watchgod>=0.8.2",
-    "sse-starlette>=1.3.3",
-    "mongo-queue-service>=0.1.8",
+    "sse-starlette>=2.1.3",
+    "mongo-queue-service>=0.2.1",
+    "yt-dlp>=2024.8.6",
 ]
 requires-python = ">=3.10"
 license = { text = "MIT" }